commit f152d5b15f50972c69021f386a806587d91a0654 Author: David Goulet dgoulet@torproject.org Date: Wed Jul 1 12:31:28 2020 -0400
test: Rename test_rep_hist to test_stats
The exposed interface is "stats/" thus make the unit tests clear that it is testing that specific GETINFO command.
Signed-off-by: David Goulet dgoulet@torproject.org --- src/test/test_controller.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/test/test_controller.c b/src/test/test_controller.c index f6dccf3bf..49efeb5f8 100644 --- a/src/test/test_controller.c +++ b/src/test/test_controller.c @@ -2134,7 +2134,7 @@ mock_rep_hist_get_circuit_handshake(uint16_t type) }
static void -test_rep_hist(void *arg) +test_stats(void *arg) { /* We just need one of these to pass, it doesn't matter what's in it */ control_connection_t dummy; @@ -2232,6 +2232,6 @@ struct testcase_t controller_tests[] = { { "getinfo_md_all", test_getinfo_md_all, 0, NULL, NULL }, { "control_reply", test_control_reply, 0, NULL, NULL }, { "control_getconf", test_control_getconf, 0, NULL, NULL }, - { "rep_hist", test_rep_hist, 0, NULL, NULL }, + { "stats", test_stats, 0, NULL, NULL }, END_OF_TESTCASES };
tor-commits@lists.torproject.org