[tor-talk] AORTA - others tried it?

Rob van der Hoeven robvanderhoeven at ziggo.nl
Sat Feb 10 09:15:48 UTC 2018

On my Debian system, programs like Firefox and Chromium do not work
> > with TorSocks. For AORTA I haven't been able to find a program that
> > does not work under AORTA. Please let me know if you have a program
> > that does not work with AORTA.
> Well, I'm not sure what is cause this:
> $ aorta -c -t telnet abcd1234abcd1234.onion 80
> WARNING NOT testing if Tor handles all Internet traffic.
> RUNNING telnet abcd1234abcd1234.onion 80
> Trying
> telnet: connect to address Connection timed out
> Trying fa93:ac5e:c801:b104:ad21:2e27:0f18:b4f...
> telnet: connect to address fa93:ac5e:c801:b104:ad21:2e27:0f18:b4f:  
> Invalid argument
> OTOH this works fine:
> $ torsocks telnet abcd1234abcd1234.onion 80
> Trying
> Connected to abcd1234abcd1234.onion.
> Escape character is '^]'.
> Why is AORTA failing, also why is result of trying to connect on
> IPV6  
> "Invalid argument"?

This is strange in multiple ways:

First the address. abcd1234abcd1234.onion cannot be a *real* onion
address because onion addresses are supposed to be unreadable :-)
I suspected it to be some kind of test address so i tried to find it in
the Tor source code. No luck. But.... 

I got a telnet reply when i tried to connect to it with AORTA. The
connection was closed immediate after i got the "Escape character is"

With torsocks the address was not resolved and no connection was

About the IPV6 address in your AORTA session. I do not know how you got
this address. AORTA should only resolve to an IPV4 address in the range.


More information about the tor-talk mailing list