[tor-talk] What is going on with /var/run/tor?

Robert Ransom rransom.8774 at gmail.com
Fri Dec 30 06:46:01 UTC 2011

On 2011-12-29, Matthew R <magickrot at gmail.com> wrote:
> I am becoming increasingly perplexed about my Tor setup.
> Tor does not appear to run on start-up.  I assume this because I cannot see
> it using ps aux | grep tor.
> My torrc is in /etc/tor/torrc with user and group set as 'root'.
> I run 'sudo tor' and receive the following errors:
> Dec 29 20:12:55.076 [notice] Tor v0.2.2.35 (git-73ff13ab3cc9570d). This is
> experimental software. Do not rely on it for strong anonymity. (Running on
> Linux i686)
> Dec 29 20:12:55.079 [notice] Initialized libevent version 1.4.13-stable
> using method epoll. Good.
> Dec 29 20:12:55.079 [notice] Opening Socks listener on
> Dec 29 20:12:55.079 [warn] Directory /var/run/tor does not exist.
> Dec 29 20:12:55.079 [warn] Before Tor can create a control socket in
> "/var/run/tor/control", the directory "/var/run/tor" needs to exist, and to
> be accessible only by the user and group account that is running Tor.  (On
> some Unix systems, anybody who can list a socket can conect to it, so Tor
> is being careful.)
> Dec 29 20:12:55.079 [notice] Closing partially-constructed listener Socks
> listener on
> Dec 29 20:12:55.080 [warn] Failed to parse/validate config: Failed to bind
> one of the listener ports.
> Dec 29 20:12:55.080 [err] Reading config failed--see warnings above.
> It is correct that /var/run/tor does not exist. I then create /var/run/tor
> with user and group as 'root' and run 'sudo tor' again:


> I don't understand why I get this error because I am 'root' not
> 'debian-tor'.  Su-ing into root then running tor provides the same error
> message:

See /usr/share/doc/tor/README.Debian .  /var/run/tor needs to be owned
by the debian-tor user and group.

Robert Ransom

More information about the tor-talk mailing list