This doubletalk is driving me nuts

Praedor Atrebates praedor at
Thu Jun 4 17:55:14 UTC 2009

On Thursday 04 June 2009 13:31:34 Ted Smith wrote:
> On Thu, 2009-06-04 at 13:28 -0400, Praedor Atrebates wrote:
> > I have just built and installed tor- in replacement for my
> > previous version.
> >
> > Nothing has changed from before this upgrade, not the location or entries
> > in my torrc, not the perms on tor, not the perms on /var/lib/tor, etc. 
> > When I try to start tor via vidalia, it now fails with messages:
> >
> > Jun 04 13:23:43.160 [Warning] Error setting groups to gid 85: "Operation
> > not permitted".
> > Jun 04 13:23:43.160 [Warning] If you set the "User" option, you must
> > start Tor as root.
> > Jun 04 13:23:43.160 [Warning] Failed to parse/validate config: Problem
> > with User value. See logs for details.
> > Jun 04 13:23:43.160 [Error] Reading config failed--see warnings above.
> >
> >
> > I have a "toruser" group set on my system.  I am a member of the toruser
> > group.  It worked before, but now it doesn't.  Then there is the
> > doubletalk - "you must start tor as root" !!!!????  I read that it is a
> > bad idea and totally unnecessary to run tor as root and here this message
> > is telling me I MUST run it as root all of a sudden.
> >
> > I want vidalia to start tor when I run it as a mere user who happens to
> > be a member of the toruser group.  How do I do this?  Nothing I do with
> > the vidalia settings changes anything and I am still prevented from
> > running tor and I will not run it as root.
> >
> > Someone, please explain/help?
> >
> > thx
> > praedor
> If you set the "User" option in torrc, Tor will try to change uid to
> that user. That capability is only available to the root user. If you
> want to run Tor as a lower user from the start, unset the "User" option.

Thanks, but if I unset the user option then it fails to start because it 
cannot create /var/lib/tor (which exists and is owned by toruser.toruser of 
which I am a member).

I do not want the lib/tor in my home I want it in one single location on my 
system.  This worked before I upgraded to so I don't understand 
why it refuses now.

"If we have Senators and Congressmen there that can't protect themselves 
against the evil temptations of lobbyists, we don't need to change our 
lobbies, we need to change our representatives." - Will Rogers

More information about the tor-talk mailing list