This doubletalk is driving me nuts

Praedor Atrebates praedor at
Thu Jun 4 17:28:52 UTC 2009

I have just built and installed tor- in replacement for my previous version.  

Nothing has changed from before this upgrade, not the location or entries in 
my torrc, not the perms on tor, not the perms on /var/lib/tor, etc.  When I 
try to start tor via vidalia, it now fails with messages:

Jun 04 13:23:43.160 [Warning] Error setting groups to gid 85: "Operation not 
Jun 04 13:23:43.160 [Warning] If you set the "User" option, you must start Tor 
as root.
Jun 04 13:23:43.160 [Warning] Failed to parse/validate config: Problem with 
User value. See logs for details.
Jun 04 13:23:43.160 [Error] Reading config failed--see warnings above.

I have a "toruser" group set on my system.  I am a member of the toruser 
group.  It worked before, but now it doesn't.  Then there is the doubletalk - 
"you must start tor as root" !!!!????  I read that it is a bad idea and 
totally unnecessary to run tor as root and here this message is telling me I 
MUST run it as root all of a sudden.  

I want vidalia to start tor when I run it as a mere user who happens to be a 
member of the toruser group.  How do I do this?  Nothing I do with the vidalia 
settings changes anything and I am still prevented from running tor and I will 
not run it as root.  

Someone, please explain/help?


"If we have Senators and Congressmen there that can't protect themselves 
against the evil temptations of lobbyists, we don't need to change our 
lobbies, we need to change our representatives." - Will Rogers

More information about the tor-talk mailing list