[tor-relays] Help with FreeBSD relays

xplato xplato at protonmail.com
Tue Mar 30 13:55:17 UTC 2021

I am running two relays and the error message is the same for both:

Mar 30 08:13:01 freebsd kernel: pod 1745 (tor) , jid 0 , uid 256, was killed: out of swap space

If I run
# dd if=/dev/zero of=/usr/swap0 bs=1m count=512

#chmod 0600 /usr/swap0

#swapon -aL

Will that fix the error above?


Sent from ProtonMail for iOS

On Tue, Mar 30, 2021 at 1:31 AM, Scott Bennett <bennett at sdf.org> wrote:

> xplato <xplato at protonmail.com> wrote:
>> I am a bit of a noob here so please bear with me. I ran a relay using Ubuntu with very few issues however I decide to add an additional relay and decided to use FreeBSD. They will only run for around 18 hours and then they shut down. I have adjust the torrc file every way I know how and increased the Max vnodes thinking this may have been my issue. I can post the sysrc and torrc if needed. Anyone that might help me figure this out I would be grateful otherwise I am going to reluctantly move them both back to Ubuntu.
> Thanks for attempting to run a relay in a diversifying environment.
> Unfortunately, your timing has left you high and dry. What is happening
> is not your fault. Both and have a fatal bug. I
> don't know which version of tor introduced it because I have been running
> until a few days ago, when I "upgraded" to
> That crashed in under 24 hours twice, so I switched to the allegedly
> "stable" version, only to have it crash the same way in about 12
> or 13 hours. Also, was filling its notice-level log file
> with many bug messages the whole time it was running. I posted a message
> on this list about it, including the last few hours of the log up through
> the crash messages. At the crash, the console log (also in /var/log/messages)
> had a message like this.
> Mar 27 18:29:26 hellas kernel: pid 17047 (tor), jid 0, uid 256: exited on signal 6
> After the second crash I made the switch mentioned above. It has been
> crashing ever since, and I am getting very tired of discovering that it has
> been down for several hours. There have been no responses to my earlier
> posting, but your query is on the same topic, if a different Subject: line,
> so I am replying.
> This sort of thing has not hit me in tor in many years, and I hope the
> tor project developers will fix it ASAP. My suggestion is that you hold
> off a bit and try again once the bug has been squashed. Alternatively, if
> you a different BSD system (i.e., DragonflyBSD, NetBSD, or OpenBSD), running
> your relay on that system would help diversify the systems running relays
> as much as, or more than, running it on FreeBSD. IOW, it depends on how
> urgently you want to get a relay up and running vs. your level of patience
> to wait for a bug fix. Like I wrote above, this situation hardly ever
> happens, so if you can be patient, it may be fixed within a few days.
> Scott Bennett, Comm. ASMELG, CFIAG
> **********************************************************************
> * Internet: bennett at sdf.org *xor* bennett at freeshell.org *
> *--------------------------------------------------------------------*
> * "A well regulated and disciplined militia, is at all times a good *
> * objection to the introduction of that bane of all free governments *
> * -- a standing army." *
> * -- Gov. John Hancock, New York Journal, 28 January 1790 *
> **********************************************************************
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.torproject.org/pipermail/tor-relays/attachments/20210330/2e202e86/attachment-0001.htm>

More information about the tor-relays mailing list