[tor-relays] difficulty installing

William Kane ttallink at googlemail.com
Wed Mar 3 14:33:36 UTC 2021


This should help you:


Installing nyx should also pull in all required packages for it to
work, as long as the ControlPort and CookieAuthentication variables
are configured correctly and nyx is ran under the same user tor is
running under (sudo -u <username> nyx).

All you have to do is set ExitRelay to 1 in your tor configuration file.

Which version of Debian are you running? Stretch?

Take a look here:


The keys provided there should work, if not, something on your system
is messed up.

> has everyone given up on the Tor project?

No, but it sounds like you are a little bit lazy when it comes to
reading manuals.. no offense, but there is more than enough
information on the internet, and I really can't understand that you
are still having these problems after "running nodes for over a

All these problems are easy to fix, given a little bit of patience and research.

Let me know if these two links helped you to get your relay running.

Contributions, like donations, code or even just running nodes, are
always welcome :-)

All the best,

2021-03-02 6:47 GMT, potlatch <potlatch at protonmail.com>:
> I've been deploying Tor nodes for over a decade--maybe several dozen or
> more. I still have ten nodes operating in six developing or smaller
> countries. Many are exits. Recently, I leased a VPS in a Eastern European
> country with permission to use it as an exit relay. This brought back some
> bad memories of a year ago when I last tried to make the Tor software
> function. The problems then are the problems I have now.
> I'm disappointed by the state of the installation packages and documentation
> these days (since a year ago at least). Tor won't start after the
> initialization message. But it displays 'If you do want to run an exit
> Relay, please set the ExitRelay option to 1 to disable this warning, and for
> forward compatibility'. Where the hell is the Exit Relay option? Then there
> is the issue of not being able to acquire the Tor keys or for the VPS to
> find the key-ring. Another message: 'The repository
> '[https://deb.torproject.org/torproject.org](https://ded.torproject.org/torproject.org)
> stretch InRelease' is not signed. Data from such a repository can't be
> authenticated and is therefore potentially dangerous to use.'
> So, is it just that the documentation is messed up or has everyone given up
> on the Tor project?
> Nyx has never completely worked for me. Never with a local config file. I
> think there are some python utilities that need to be installed to make it
> work. I never asked but no one ever offered. The documentation is silent
> regarding this point. The old ARM software would give me an idea of how many
> file descriptors I was using and if I had provided enough. Arm also filled
> in the users list with column information instead of providing mostly ????.
> I donate regularly to Tor, EFF and Riseup. It's what I believe in. Does Tor
> need some volunteer help? I can only code python--would that help?
> potlatch in WA State
> Sent with [ProtonMail](https://protonmail.com) Secure Email.

More information about the tor-relays mailing list