[tor-relays] Strange OpenPGP behavior during key import under Debian Buster

Roger Dingledine arma at torproject.org
Sun Nov 17 21:34:21 UTC 2019

On Sat, Nov 16, 2019 at 02:22:58PM +0100, Olaf Grimm wrote:
> Ok, curl works now after update, although I also see this strange last
> line in STOUT.


> My somewhat hidden question or hint is that I edited the key file by
> hand and the import suddenly works. I have the impression I accidentally
> fixed the download changed by 'wget' with the editor. I removed a
> 'carriage return'. This also changes the file content.
> Is that possible or is there a deeper problem?

No, that is likely not what solved the problem. The previous problem was
that you were running the wrong command.

If you run "wget ... | gpg", that means to take what wget outputs on
the command line and send that as input into the gpg program. But wget
outputs basically nothing on its command line: all it does is download
the url and store it to a file. So when you send that 'basically nothing'
to gpg, of course gpg can't find any useful keys in it.

Or as Roman said very well,

  curl ... | gpg ...  <- will work


  wget ... | gpg ...  <- will not

> By the way, curl is not default in Debian Buster.

Yeah, we should probably fix all the guides to say "wget -O - ..." rather
than "curl ..." so we aren't forcing people to install a new program just
for this situation. Though I wonder if that will produce more confusion,
because people won't paste or type it correctly. We'll see I guess!


More information about the tor-relays mailing list