[tor-relays] Tor relay says it is reachable, but is not appearing on the network.

teor teor at riseup.net
Fri May 24 04:44:51 UTC 2019


> On 24 May 2019, at 11:41, Keifer Bly <keifer.bly at gmail.com> wrote:
> Hi all, so I believe I found the problem. In my torrc file, there was a rogue line which read "PublishServerDescriptor" with nothing after it. I removed this line and restarted the relay, now it is saying "May 24 01:38:16.000 [notice] Self-testing indicates your ORPort is reachable from the outside. Excellent. Publishing server descriptor.
> May 24 01:38:20.000 [notice] Performing bandwidth self-test...done."
> So it seems this solved the problem.

It looks like your relay changed keys about 2 hours ago:

If you keep changing your relay keys, it won't be used very much.

> Now, I am also wondering, is there a tool that can be used to automatically update tor? Thank you.


From my last email:

>>> When I tried updating tor I got a message saying that was the
>>> newest version.
>> It looks like you're on Debian or Ubuntu, please follow these instructions
>> to update:
>> https://2019.www.torproject.org/docs/debian.html.en

>>> May 21 20:01:32.000 [warn] You are running Tor as root. You don't need to, and you probably shouldn't.
>> I don't know how you are configuring and running your relay. Using a guided
>> relay configuration tool might help you. See my suggestion below.

>> You seem to have a lot of trouble configuring relays manually.
>> You might have a better experience with a guided setup tool, like this
>> Tor Relay role in Ansible:
>> https://github.com/nusenu/ansible-relayor

I really think that something like ansible is your best chance of having a
working relay.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: Message signed with OpenPGP
URL: <http://lists.torproject.org/pipermail/tor-relays/attachments/20190524/1085cbb6/attachment.sig>

More information about the tor-relays mailing list