[tor-relays] tor enters uninterruptible sleep forever when using transparent proxy

Nicolás Dato nicolas.dato at gmail.com
Tue May 22 14:38:04 UTC 2018

Hello there,
First thanks for reading!

I've been running a tor relay for almost two weeks from my home.
Yesterday,* I did some upgrades to my Slackware 14.2 including glibc and
kernel*. I run tor there and it worked fine. After upgrading Slackware I
had to reboot and run windows for the night. Windows messes with the
machine time.
Today, *I rebooted and run Slackware and (as usual after running windows) *the
clock was -3 hours apart. I do run NTP but looks like it doesn't make the
adjustment if the difference is way too big. I adjusted the time and run
the NTP service again.
*Tor daemon launches at startup* so it was running when my clock was -3
hours from present time.

I use irssi (IRC client) connecting to the tor transparent proxy using
As usual, I runned irssi and tried to connect to a server but the
connection hangs forever and tor hangs forever too, hanging the relay too.
I tried a different server but hangs too.

*Before trying to connect with irssi, this works:*
The tor relay works fine and accepts connections and delivers traffic.
I can run nyx and it connects fine and shows me the stats.
I can connect to the socks proxy and it works and doesn't hangs tor daemon.

After trying to connect with irsse,
*all of that stop working.*
I didn't changed any tor configuration neither the iptables configuration
I did build the tor packages (recompiling it) and installed it, but didn't
I removed some files and folders from /var/log/tor, only removed the ones
modified yesterday and today, but it didn't work neither.

tor is reported by ps to be on uninterruptible sleep
 1347 ?        Dl     0:06     11     0 491216 87432  2.2 /usr/bin/tor
and there is no way to kill it other than rebooting, neither kill -9 as
root works

after all the reboots, after removing some /var/lib/tor files, and having
the machine clock on time, tor still hangs when using the transparent proxy

this are the last lines from the debug log:
(that's from the time I tried to connect to freenode and it hanged, no more
logs after that)

this is my iptables:
(irssi runs as ircuser)

this is my torrc:
(I didn't copy some lines)

Thanks again for reading.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.torproject.org/pipermail/tor-relays/attachments/20180522/64b9173b/attachment.html>

More information about the tor-relays mailing list