[tor-relays] Thoughts on automatically updating tor software on macos High Sierra

teor teor2345 at gmail.com
Tue Jul 10 04:39:01 UTC 2018

> On 10 Jul 2018, at 13:50, Keifer Bly <keifer.bly at gmail.com> wrote:
> Tried that twice now and it has not worked. It’s strange, the error terminal returns when trying to launch the script to upgrade tor is this
> iMac:~ oldimac$ launchctl load -w /Library/LaunchDaemons/starttorupgrade.plist
> /Library/LaunchDaemons/starttorupgrade.plist: Path had bad ownership/permissions

Check out the first result for:

> This is very odd. I set the permissions to read and write for all users, but yet this error is still happening. I changed the permissions for the whole lanchdaemons folder as well and still no resolve to this. I even tried signing into the root user in Terminal to see if that would resolve the issue, it did not.

"It is also worth noting that these root LaunchDaemons can't be world writable, for security reasons:"

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.torproject.org/pipermail/tor-relays/attachments/20180710/3c4efbdf/attachment.html>

More information about the tor-relays mailing list