[tor-relays] building Tor against LibreSSL 2.1.1 fails with "undefined reference to `EVP_aes_128_ctr'" error

Seth list at sysfu.com
Tue Jan 13 22:19:17 UTC 2015

On Sun, 28 Dec 2014 16:01:12 -0800, Nick Mathewson <nickm at freehaven.net>  

> Maybe the autoconf script is looking at the headers in /usr/include,
> instead of /usr/local/include ? That would mess it up.
> Instead of using --with-openssl-dir=/usr/local, what happens if you
> set CFLAGS and LDFLAGS by hand when compiling?

I tried to find out how to do this by myself but I don't understand very  
well how these flags work.

Could you please provide some examples and I'll test?

Also of note, I was able to get tor- to build succesfully on  
a the release version of OpenBSD 5.6 which includes LibreSSL 2.0-something.

When I tried to  build tor- against libressl 2.1.2 on the  
same system using ./configure --with-openssl-dir=/usr/local it bails out  
with same the tortls.o error.

> For the meantime, is there a compiler macro we can use to distinguish
> libressl from openssl at compile-time?

Do not know.

More information about the tor-relays mailing list