[tor-relays] obfsproxy not working on bridge relay - solved?

jchase jchase at riseup.net
Wed Oct 8 20:59:29 UTC 2014

> From: George Kadianakis <desnacked at riseup.net>
> To: tor-relays at lists.torproject.org
> Subject: Re: [tor-relays] obfsproxy not working on bridge relay
> Message-ID: <874mve973h.fsf at riseup.net>
> Content-Type: text/plain
> jchase <jchase at riseup.net> writes:
>> Hi,
>> Due to m limited bandwidth I've decided to turn my relay into a bridge.
>> I seem to have everything right except if I restart tor I get a warning
>> that "managed proxy obfsproxy is 'closed'". I'm sure this has come up in
>> the past but I can find it in the archives.
>> In torrc I have:
>> SocksPort 0
>> ORPort 9001
>> Exitpolicy reject *:*
>> Log notice file /var/log/tor/notices.log
>> Contact info []
>> Nickname rasptorholland
>> BridgeRelay 1
>> ServerTransportPlugin obfs3 exec /usr/bin/obfsproxy managed
>> ServerTransportListenAddr obfs3
>> DisableDebuggerAttachment 0
> Hello,
> how did you install obfsproxy? Which installation instructions did you
> follow? Seems like you didn't follow:
> https://www.torproject.org/projects/obfsproxy-instructions.html.en
> What happens if you run '/usr/bin/obfsproxy managed' in a terminal?

Thanks for your advice! I had installed obfsproxy with apt-get on a Pi.
I removed that and tried pip. It took me a while to find out that pip
was actually python-pip. (Maybe the Tor website could be more specific
about that.) That install went well. You asked me to see what happened
after the command '/usr/bin/obfsproxy managed'. It took me a while to
find that obfsproxy was installed in /usr/local/ , not in /usr/bin/ .
And now, until further notice from tor, things seem to work fine.
J. Chase

More information about the tor-relays mailing list