[tor-dev] [RFC] control-spec: Specify add/remove/view client auth commands (client-side).
grarpamp at gmail.com
Tue May 7 22:15:09 UTC 2019
On 5/7/19, Suphanat Chunhapanya <haxx.pop at gmail.com> wrote:
> That's cool. But according to what dgoulet proposed, if we use both
> and ONION_SERVICE_AUTH_ADD. The latter will sound like it's an
> authentication of the service not the client. At least for me :)
And or maybe that seem more like managing the
onion service ID itself too, rather than just authentication
for fetching or connecting to it.
Part of problem may be brain grouping of the underscores.
"onion" "client|service" "auth" "add|del|view"
"onion" "client|service auth" "add|del|view"
"onion client|service" "auth" "add|del|view"
> If you want the least specific left and the most specific right, I think
> ONION_AUTH_CLIENT_ADD and
> ONION_AUTH_SERVICE_ADD would be better.
Maybe your sense would be better...
"onion auth" for "client|service" do "add|del|view"
or if there's want to keep "onion" string as the MIB root...
"onion" re "auth" for "client|service" do "add|del|view"
Though seems mostly agreed on onion first and verb last,
so whatever works for people in the middle :)
More information about the tor-dev