[tor-dev] Failure to connect to a bridge--downgrading to fixes it

David Fifield david at bamsoftware.com
Sat Dec 8 21:26:14 UTC 2018

On Thu, Dec 06, 2018 at 10:19:09PM -0700, David Fifield wrote:
> Here, a user reported a failure to connect to their own bridge, stopping
> at 25% bootstrapped. teor and I went through the basic troubleshooting
> steps of checking the bridge syntax, system time, and firewall settings.
> With or without obfs4 didn't make a difference. The user eventually
> tried downgrading the bridge from to that fixed
> it. Their client version was
> https://bugs.torproject.org/28717#comment:18
> They also tried with two bridges from BridgeDB. The one running
> didn't work, and the one running did.
> A possible lead are these client log messages:
> [info] handle_response_fetch_desc(): Received server info (body size 0) from server 'X.X.X.X:YYYY'
> [info] handle_response_fetch_desc(): Received http status code 404 ("Servers unavailable") from server 'X.X.X.X:YYYY' while fetching "/tor/server/authority.z". I'll try again soon.

The problem started in, according to the user's tests of
multiple versions on the bridge.

working (git-31cc63deb69db819)
working (git-2e94df92caee0fca)
working (git-7dd0813e783ae16e)
working (git-035a35178c92da94)
working (git-45028085ea188baf)
not working (git-deb8970a29ef7427)
not working (git-bc951e83aac770d1)
not working (git-6045c26d8442913e)
not working (git-8465a8d84647c349)
not working (git-da95b91355248ad8)
not working (git-4ac3ccf2863b86e7)

More information about the tor-dev mailing list