[tor-dev] Tor Browser videos Automation

Isabela isabela at riseup.net
Thu Jul 9 16:23:45 UTC 2015

+ tor-dev

Sorry for the noise, but thought of expanding the audience a little,
maybe someone the time to take look into this, or might know what is
going on.

Any help is appreciated, we are trying to finish this project and this
has been blocking us.


Sherief Alaa:
> On Mon, May 18, 2015 at 3:49 PM, Mark Smith <mcs at pearlcrescent.com> wrote:
>> On 5/17/15 6:54 AM, Sherief Alaa wrote:
>>> Hi Georg/Mark,
>>> I am working on the new Tor Browser videos this month (or at least a
>>> process to produce them in an automated manner). I am contacting you
>>> because I am running into a problem that you may know how to solve
>>> because I think it's browser related.
>>> Karsten insisted that I have to run a local copy of torproject.org
>>> <http://torproject.org> using a web server while the automated script
>>> runs since we can't estimate or depend on the connection speed. The
>>> major blocker in this is that the browser redirects to
>>> https://torproject.org/ whenever I try to map to
>>> torproject.org <http://torproject.org> (or www.torproject.org
>>> <http://www.torproject.org>) in my /etc/hosts file. Now I've tried
>>> everything that will come up to mind that may solve the problem, such
>>> as: flushing DNS cache, clearing history, disabling all addons and more
>>> but nothing worked.
>>> I also ran Wireshark to inspect DNS packets but the browser doesn't even
>>> try to query any DNS server.
>>> I've tested on OS X and Ubuntu and both produce the same results. I've
>>> also tested multiple browsers (Safari, Chrome and Firefox). Same results.
>>> Trivial note: During testing, I could map google.com
>>> <http://google.com>, ign.com <http://ign.com> and basically all .coms
>>> but never for .orgs like eff.org <http://eff.org> or torproject.org
>>> <http://torproject.org>
>>> If you have any idea what's going on, please let me know as soon as
>>> possible as I am considering running a local nameserver but I am keeping
>>> that as a last resort.
>> I do not know what is going on.  Most likely it is a caching problem (both
>> the OS and browser cache DNS info, as you know).  But Kathy (CC'd on this
>> reply) and I experimented a little on Mac OS 10.9.5 and found like you did
>> that some hosts worked and some did not, even after doing dscacheutil
>> -flushcache and using Firefox with a new profile.  From the command line,
>> ping always seems to respect /etc/hosts but other things such as curl do
>> not.  Which I guess means it is an OS caching issue, or some applications
>> have their own DNS resolver that bypasses the OS libraries.
>> -Mark
> Ccing Isabela
> -- 
> PM at TorProject.org
> gpg fingerprint = 8F2A F9B6 D4A1 4D03 FDF1  B298 3224 4994 1506 4C7B
> @isa

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: OpenPGP digital signature
URL: <http://lists.torproject.org/pipermail/tor-dev/attachments/20150709/6dfb8148/attachment.sig>

More information about the tor-dev mailing list