[tor-dev] Orbot Fails to Transparent Proxy on lge-e739

Jordan jordannh at sent.com
Thu Sep 4 23:20:02 UTC 2014

Hi, all,

I'm writing this not as a bug ticket: I'd like to try to get involved with fixing this issue (which is why I cc'd you, Nathan).

Orbot seems to fail transparent proxy. Here's my device info, probably more for humor than for information:

    - Device: LGE E739 (T-Mobile MyTouch).
    - Android Kernel: Linux localhost #1 PREEMPT
    - Cyanogenmod Version: cyanogenmod 9
    - Default iptables version: v1.4.14

Just a side note, that this bug doesn't seem to occur on certain versions of orbot (more on that later).

Here are the properties of what happens when Orbot "fails to transparent proxy."

    - I can't get a mobile data connection.
    - I am able to connect to Wi-Fi just fine. However...
    - Some applications (specifically, **K-9 mail**), throw IOExceptions.

I've tried to do a better job at tracking on which versions of Orbot this occurs, however, based on the last three releases, this is what I have found:

    - version No TP
    - version No TP
    - version 17.0.6: TP worked initially, and then randomly failed, even after I cleared iptables rules and reinstalled.

For any version, it didn't seem to matter if I had a firewall installed (I tested both droidwall and AFWall+...and no firewall, too).

I'm currently trying my hand at porting CM 11 to my device (having..."fun" do they call it?), but I figured I could try to get Orbot working in the meantime. Is this an issue to be resolved? I realize I'm using an out-dated kernel. Could it be an iptables issue?

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 490 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.torproject.org/pipermail/tor-dev/attachments/20140904/a8ee4ee3/attachment.sig>

More information about the tor-dev mailing list