[tor-dev] Format-Transforming Encryption Pluggable Transport

Kevin P Dyer kpdyer at gmail.com
Sat Jul 27 22:23:34 UTC 2013

Hi George,

I've released FTE v0.1.2-alpha. This release includes bug fixes and an
improved build process. You can obtain the new builds from the
official FTE website: https://kpdyer.com/fte/

The v0.1.2-alpha binaries have been tested on Ubuntu 12.10, Ubuntu
13.04, RHEL 6.4 and OSX 10.8.4. The 32-bit/64-bit linux binaries were
compiled on RHEL6.4 with GLIBC 2.12.

Please let me know if this resolves the issue you encountered.


On Wed, Jul 24, 2013 at 10:51 PM, Kevin P Dyer <kpdyer at gmail.com> wrote:
> Hi George,
> Thanks for trying FTE!
> Apologies, this is my fault. I built the current packages on a recent
> Ubuntu version with GLIBC 2.14. On execution, the binary is looking
> for GLIBC >=2.14, which isn't available on your system. Hence, the
> bundle and binary won't execute properly.
> Which Linux distro/version are you running?
> To resolve the issue you have three options:
> 1. Wait for me to build binaries that work on a broader range of systems.
> 2. Try the binary on a different machine.
> 3. Build FTE from source.
> I expect you'll prefer option one. So, I'll be sure to release new
> binaries ASAP.
> -Kevin
> On Wed, Jul 24, 2013 at 7:44 PM, George Kadianakis <desnacked at riseup.net> wrote:
>> Hi Kevin,
>> I tried the bundles in https://kpdyer.com/fte/ .
>> For some reason, when I fire up 'start-tor-browser' I don't get
>> 'fte_relay' listener to bind on '' (like the torrc expects
>> it to). Hence Tor fails to bootstrap and simply says:
>> "The connection to the SOCKS5 proxy server at just failed.
>> Make sure that the proxy server is up and running."
>> When I run 'start-tor-browser' I'm getting the following message in stdout:
>> """
>> ./bin/fte_relay: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not
>> found (required by /tmp/_MEI8IBYIj/libz.so.1)
>> """
>> could this be why fte_relay never sets up a listener?
>> Also, if I try to manually invoke fte_relay by doing:
>> ./bin/fte_relay --mode client --server_ip --server_port 8080
>> I get the same error.
>> Furthermore, I can't get ./bin/fte_relay to give me some kind of usage
>> information.
>> Any ideas?
>> Thanks!

More information about the tor-dev mailing list