[tor-dev] Format-Transforming Encryption Pluggable Transport

George Kadianakis desnacked at riseup.net
Wed Jul 24 23:44:25 UTC 2013

Hi Kevin,

I tried the bundles in https://kpdyer.com/fte/ .

For some reason, when I fire up 'start-tor-browser' I don't get
'fte_relay' listener to bind on '' (like the torrc expects
it to). Hence Tor fails to bootstrap and simply says:
"The connection to the SOCKS5 proxy server at just failed.
Make sure that the proxy server is up and running."

When I run 'start-tor-browser' I'm getting the following message in stdout:
./bin/fte_relay: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not
found (required by /tmp/_MEI8IBYIj/libz.so.1)
could this be why fte_relay never sets up a listener?

Also, if I try to manually invoke fte_relay by doing:
./bin/fte_relay --mode client --server_ip --server_port 8080
I get the same error.

Furthermore, I can't get ./bin/fte_relay to give me some kind of usage

Any ideas?


More information about the tor-dev mailing list