[tor-dev] Testing in Tor [was Re: Brainstorming a Tor censorship analysis tool]

Simon simonhf at gmail.com
Thu Dec 20 19:13:00 UTC 2012

On Thu, Dec 20, 2012 at 10:50 AM, Damian Johnson <atagar at torproject.org> wrote:
>> So I have a built and make tested tor- folder and stem/ in a
>> parallel folder. When I run the command then I get the following:
>> $ ./run_tests.py --integ
>> Unable to start tor, 'tor' does not exists.
>> How can I run the tests on the Tor built in the tor- folder?
> Just run './run_tests.py --integ --tor /path/to/tor'. Without the
> '--tor' argument it uses the tor instance in your path (and you
> evidently don't have one).

Thanks. That gets me a bit further but it fails as follows:

$ ./run_tests.py --integ --tor ../tor-

Performing startup activities...
  checking for orphaned .pyc files... done

                          INTEGRATION TESTS

Setting up a test instance...
  making test directory (/home/simon/work/20121219-tor/stem/test/data)... done
  configuring logger (/home/simon/work/20121219-tor/stem/test/data/log)... done
  writing torrc (/home/simon/work/20121219-tor/stem/test/data/torrc)... done
    # configuration for stem integration tests
    DataDirectory /home/simon/work/20121219-tor/stem/test/data
    SocksPort 1112
    DownloadExtraInfo 1
    ControlPort 1111

Starting tor...

  failed to start tor: [Errno 13] Permission denied

Shutting down tor... done
Shutting down tor... done
TESTING PASSED (0.1 seconds)

Is that a bug that it says 'TESTING PASSED' even though it failed to
start Tor? Is the permission denied error because I need to be root to
run the tests? If so, how to change the tests so that being root isn't


More information about the tor-dev mailing list