[tor-commits] [tor/master] Rename 'relay_crypt' to 'relay_decrypt_cell'

nickm at torproject.org nickm at torproject.org
Thu Apr 5 16:31:45 UTC 2018


commit 298932605495dc9ef3e8e068c36a80a517036195
Author: Nick Mathewson <nickm at torproject.org>
Date:   Sat Mar 17 10:03:53 2018 -0400

    Rename 'relay_crypt' to 'relay_decrypt_cell'
    
    This function is used upon receiving a cell, and only handles the
    decrypting part.  The encryption part is currently handled inside
    circuit_package_relay_cell.
---
 src/or/relay.c | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/src/or/relay.c b/src/or/relay.c
index 7c21839a8..fad8b38b4 100644
--- a/src/or/relay.c
+++ b/src/or/relay.c
@@ -299,7 +299,8 @@ circuit_receive_relay_cell(cell_t *cell, circuit_t *circ,
   if (circ->marked_for_close)
     return 0;
 
-  if (relay_crypt(circ, cell, cell_direction, &layer_hint, &recognized) < 0) {
+  if (relay_decrypt_cell(circ, cell, cell_direction, &layer_hint, &recognized)
+      < 0) {
     log_fn(LOG_PROTOCOL_WARN, LD_PROTOCOL,
            "relay crypt failed. Dropping connection.");
     return -END_CIRC_REASON_INTERNAL;
@@ -422,8 +423,9 @@ circuit_receive_relay_cell(cell_t *cell, circuit_t *circ,
  * else return 0.
  */
 int
-relay_crypt(circuit_t *circ, cell_t *cell, cell_direction_t cell_direction,
-            crypt_path_t **layer_hint, char *recognized)
+relay_decrypt_cell(circuit_t *circ, cell_t *cell,
+                   cell_direction_t cell_direction,
+                   crypt_path_t **layer_hint, char *recognized)
 {
   relay_header_t rh;
 





More information about the tor-commits mailing list