[tor-commits] [tor/master] Fix a few warnings from lintChanges

nickm at torproject.org nickm at torproject.org
Mon Dec 12 13:31:15 UTC 2016


commit 9025991a8d16b28e0b1ed875aab76630f9aa1715
Author: Nick Mathewson <nickm at torproject.org>
Date:   Mon Dec 12 08:31:05 2016 -0500

    Fix a few warnings from lintChanges
---
 changes/bug20530     |  4 ++--
 changes/bug20646     |  6 +++---
 changes/feature17238 |  4 ++--
 changes/feature20552 |  2 +-
 changes/ticket18873  | 13 ++++++++-----
 changes/ticket20717  |  5 ++---
 6 files changed, 18 insertions(+), 16 deletions(-)

diff --git a/changes/bug20530 b/changes/bug20530
index c21d5fb..85d1b01 100644
--- a/changes/bug20530
+++ b/changes/bug20530
@@ -1,4 +1,4 @@
-  o Minor Fixes (Windows):
+  o Minor bugfixes (Windows):
     - Check for getpagesize before using it to mmap files. This fixes
       compilation in some MinGW environments. Fixes bug 20530; bugfix on
-      commit bf72878 in tor-0.1.2.1-alpha, reported by "ice".
+      0.1.2.1-alpha. Reported by "ice".
diff --git a/changes/bug20646 b/changes/bug20646
index 42e319f..7cff38f 100644
--- a/changes/bug20646
+++ b/changes/bug20646
@@ -1,5 +1,5 @@
-  o Minor bugfix (util)
+  o Minor bugfix (util):
     - When finishing writing a file to disk, if we were about to replace the
       file with the temporary file created before and we fail to replace it,
-      remove the temporary file so it doesn't stay on disk. Closes #20646;
-      bugfix on tor-0.2.0.7-alpha; Patch by fk.
+      remove the temporary file so it doesn't stay on disk. Fixes bug 20646;
+      bugfix on tor-0.2.0.7-alpha. Patch by fk.
diff --git a/changes/feature17238 b/changes/feature17238
index eba9fb7..88dfee9 100644
--- a/changes/feature17238
+++ b/changes/feature17238
@@ -1,6 +1,6 @@
-  o Major features (onion service)
+  o Major features (onion services):
     - Tor relays now support the HSDir version 3 protocol meaning they can
       store and serve v3 descriptors. This is part of the next generation
       onion service work detailled in proposal 224. The tor daemon also
       contains all the necessary code to encode and decode a v3 descriptor but
-      it's currently only used by the directory subsystem. Closes #17238.
+      it's currently only used by the directory subsystem. Closes ticket 17238.
diff --git a/changes/feature20552 b/changes/feature20552
index 1195480..75fbdde 100644
--- a/changes/feature20552
+++ b/changes/feature20552
@@ -1,4 +1,4 @@
   o Minor features (ed25519 link handshake):
     - Advertise support for the ed25519 link handshake using the
       subprotocol-versions mechanism, so that clients can tell which
-      relays can identity themselves by Ed25519 ID.
+      relays can identity themselves by Ed25519 ID. Closes ticket 20552.
diff --git a/changes/ticket18873 b/changes/ticket18873
index f1d9bef..11a867d 100644
--- a/changes/ticket18873
+++ b/changes/ticket18873
@@ -1,7 +1,10 @@
   o Code simplification and refactoring:
-    - Extracted dummy_origin_circuit_new so it can be used by other test
+    - Refactor circuit_predict_and_launch_new for readability and
+      testability. Closes ticket 18873.
+    - Extract magic numbers in circuituse.c into defined variables.
+    - Refactor circuit_is_available_for_use to remove unnecessary check.
+
+  o Minor features (unit tests):
+    - Extract dummy_origin_circuit_new so it can be used by other test
       functions.
-    - Refactor circuit_predict_and_launch_new for readability and testability.
-    - Added unit tests for extracted functions.
-    - Extracted magic numbers in circuituse.c into defined variables.
-    - Refactor circuit_is_available_for_use to remove unnecessary check
+    - Add unit tests circuit_predict_and_launch_new.
diff --git a/changes/ticket20717 b/changes/ticket20717
index c896f8a..71d3edd 100644
--- a/changes/ticket20717
+++ b/changes/ticket20717
@@ -1,4 +1,3 @@
   o Code simplification and refactoring:
-    - Refactors the hashing API to return negative values for errors as is done
-      as a standard throughout the codebase.
-    - Refactors calling functions to expect negative values for errors.
+    - Refactor the hashing API to return negative values for errors, as is done
+      as throughout the codebase. Closes ticket 20717.



More information about the tor-commits mailing list