[tor-commits] [tor/master] fixup! Move encode_cert to torcert.c and rename it to tor_cert_encode_ed22519()

nickm at torproject.org nickm at torproject.org
Thu Dec 1 14:23:52 UTC 2016


commit a3bbb9ce775d5ad250c50852785fcabdff155685
Author: David Goulet <dgoulet at torproject.org>
Date:   Thu Nov 10 11:00:59 2016 -0500

    fixup! Move encode_cert to torcert.c and rename it to tor_cert_encode_ed22519()
---
 src/or/hs_descriptor.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/src/or/hs_descriptor.c b/src/or/hs_descriptor.c
index 3a536e7..c48d717 100644
--- a/src/or/hs_descriptor.c
+++ b/src/or/hs_descriptor.c
@@ -134,6 +134,7 @@ desc_encrypted_data_free_contents(hs_desc_encrypted_data_t *desc)
   memwipe(desc, 0, sizeof(*desc));
 }
 
+/* === ENCODING === */
 
 /* Encode the given link specifier objects into a newly allocated string.
  * This can't fail so caller can always assume a valid string being





More information about the tor-commits mailing list