[tor-commits] [tor/master] Rename SLIST_ENTRY to TOR_SLIST_ENTRY to fix windows compilation

nickm at torproject.org nickm at torproject.org
Thu Nov 1 21:42:47 UTC 2012


commit ae99fc1ccb91ff3f7f23962377a5ffe0d92ef9a1
Author: Nick Mathewson <nickm at torproject.org>
Date:   Thu Nov 1 17:40:27 2012 -0400

    Rename SLIST_ENTRY to TOR_SLIST_ENTRY to fix windows compilation
    
    Apparently winnt.h defines a different SLIST_ENTRY of its own.
    
    Bug not in any version of Tor.
---
 src/ext/tor_queue.h |    4 +++-
 1 files changed, 3 insertions(+), 1 deletions(-)

diff --git a/src/ext/tor_queue.h b/src/ext/tor_queue.h
index 622301d..98d6b98 100644
--- a/src/ext/tor_queue.h
+++ b/src/ext/tor_queue.h
@@ -99,7 +99,9 @@ struct name {								\
 #define	SLIST_HEAD_INITIALIZER(head)					\
 	{ NULL }
  
-#define SLIST_ENTRY(type)						\
+/* XXXX This macro name conflicts with a typedef in winnt.h, so Tor
+ * has to redefine it. */
+#define TOR_SLIST_ENTRY(type)						\
 struct {								\
 	struct type *sle_next;	/* next element */			\
 }



More information about the tor-commits mailing list