[tor-bugs] #18105 [Core Tor/Tor]: Replace getsockname with tor_getsockname

Tor Bug Tracker & Wiki blackhole at torproject.org
Thu Nov 16 21:25:44 UTC 2017

#18105: Replace getsockname with tor_getsockname
 Reporter:  teor                                 |          Owner:
                                                 |  eewayhsu
     Type:  enhancement                          |         Status:
                                                 |  needs_revision
 Priority:  Medium                               |      Milestone:  Tor:
                                                 |  0.3.3.x-final
Component:  Core Tor/Tor                         |        Version:
 Severity:  Normal                               |     Resolution:
 Keywords:  easy, intro, api, code-              |  Actual Points:
  simplification                                 |
Parent ID:                                       |         Points:  small
 Reviewer:                                       |        Sponsor:

Comment (by teor):

 Ah, C header dependencies. Not fun.

 That probably means that this new function:
 * should be in address.c, and
 * should call tor_getsockname(), rather than replacing it.

 How about tor_addr_from_getsockname()?
 That's a much better name anyway, because it describes exactly what the
 function does.

Ticket URL: <https://trac.torproject.org/projects/tor/ticket/18105#comment:20>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online

More information about the tor-bugs mailing list