[tor-bugs] #11291 [Tor]: Support group readable hidden service directories

Tor Bug Tracker & Wiki blackhole at torproject.org
Wed May 14 19:35:51 UTC 2014


#11291: Support group readable hidden service directories
-----------------------------+--------------------------------
     Reporter:  anon         |      Owner:
         Type:  enhancement  |     Status:  needs_revision
     Priority:  normal       |  Milestone:  Tor: 0.2.6.x-final
    Component:  Tor          |    Version:
   Resolution:               |   Keywords:  tor-hs
Actual Points:               |  Parent ID:
       Points:               |
-----------------------------+--------------------------------
Changes (by nickm):

 * status:  needs_review => needs_revision


Comment:

 Quick review:

  * Will the tests pass on windows?  (Will they compile on windows?)
  * Are symbolic constants really necessary here for the STAT_* stuff?  (In
 theory, we already have standard symbolic constants as S_IRUSR, S_IRUSR,
 S_IXUSR.... but, does having them really make the code cleaner?  Is
 `STAT_RWXU|STAT_RGRP|STAT_XGRP` really easier to read than `0750` ?)
  * Our coding style is to write '} else {' on one line.
  * The style changes at the start of rendservice.c don't have anything to
 do with the rest of the patch.
  * The comment opening `/**` is only for doxygen comments.
  * Should `HiddenServiceGroupReadable` be `HiddenServiceDirGroupReadable`
 ?
  * check_private_dir() ensures that the directory has bits 0700 if
 CPD_CHECK_MODE_ONLY is not set.  Shouldn't it also ensure that the
 directory has bits 0050 if CPD_CHECK_MODE_ONLY is not set, and
 CPD_GROUP_READ is set?
  * Does it make sense for HiddenServiceGroupReadable to be a per-hidden-
 service option?

--
Ticket URL: <https://trac.torproject.org/projects/tor/ticket/11291#comment:12>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online


More information about the tor-bugs mailing list