[tor-bugs] #10754 [Tor Support]: Implement an invitation based token system into webchat

Tor Bug Tracker & Wiki blackhole at torproject.org
Thu May 1 12:51:38 UTC 2014


#10754: Implement an invitation based token system into webchat
-----------------------------+----------------------------
     Reporter:  Sherief      |      Owner:  Sherief
         Type:  task         |     Status:  needs_revision
     Priority:  blocker      |  Milestone:
    Component:  Tor Support  |    Version:
   Resolution:               |   Keywords:  SponsorO
Actual Points:               |  Parent ID:  #10755
       Points:               |
-----------------------------+----------------------------

Comment (by lunar):

 Another review:

 Please use a commonly accepted license. That will prevent legal headaches.
 If you want to give freedom to developers, BSD-3-clause like Tor is just
 fine. If you want to give freedom to users, AGPLv3 is what we need.
 Actually `prodomus.js` is licensed under AGPLv3 already.

 The `createuser` command should exit with a non-zero status code when
 unable to create an user. Same with `deleteuser`.

 The `pups/settings.py` should not be commited to the repository and should
 probably be in `.gitignore`.

 Page title in HTML templates in `pups/templates` might need to be updated
 to reflect the new application name.

 `pups/templates/nav_bar.html` contains a commented tag without
 explanations in the header.

 `pups/templates/pups.html` says “Nothing interesting here yet but I'll
 think of something.”

 License of Bootstrap files should be mentioned in the README. Same with
 the webfont. Same with jQuery. Same with Strophe. Same with Prodomus.

 `prodromus.js` contains non internationalizable strings (e.g. `VARIABLE +
 "something"`). Sprintf-like functions should be used instead.

 In `promodus.js`, `isAvailable` is ill-named. It should not be named
 `isSomething` if it does not hold a boolean value. Right now, this
 variable can have four different values "null", "0", "1", and "2". Their
 actual meaning is unclear by reading the source code. Constants should be
 used instead of magic numbers. Usage of "null" on top of the actual values
 does not look like a good idea.

 extra `<div>` in `pups_project/webchat/templates/prodromus.html`

 The `LoginForm` defined in `webchat/forms.py` should probably be in the
 `pups` module instead.

 `Token.revoke_token` should be named `revoke_tokens` as it takes a list.

 The code is still not following PEP8 in many places:
 {{{
 $ pep8 . | wc -l
 109
 }}}

 I could also work on the code if needed.

--
Ticket URL: <https://trac.torproject.org/projects/tor/ticket/10754#comment:40>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online


More information about the tor-bugs mailing list