[tbb-dev] Are incremental updates working?

Mike Perry mikeperry at torproject.org
Thu Dec 11 22:31:14 UTC 2014

Mark Smith:
> On 12/10/14 2:59 PM, Georg Koppen wrote:
> >Mark Smith:
> >>The "failed: 4" tells us that the error was CRC_ERROR (see
> >>https://gitweb.torproject.org/tor-browser.git/tree/toolkit/mozapps/update/common/errors.h).
> >>
> >>
> >>The update.log file should contain more details, but that may be gone
> >>now.  You might look around for a file named update.log,
> >>backup-update.log, or last-update.log
> >
> >Seems I still had a backup-update.log lying around, yay. It is attached.
> Thanks!  Your log has:
> ...
> EXECUTE PATCH application.ini
> EXECUTE PATCH TorBrowser/Tor/libgmp.so.10
> EXECUTE PATCH TorBrowser/Docs/sources/versions
> LoadSourceFile: destination file crc -1802735353 does not match
> expected crc -131947685
> // In hex:                           0x948C7107      0xF822A35B
> LoadSourceFile failed
> ### execution failed
> ...
> This error should mean that at the time the incremental update was
> being applied, the file TorBrowser/Docs/sources/versions within the
> existing installation did not have the same contents as the one in
> the original 4.5-alpha-1 package.  The file size must have been the
> same because the size check comes before the crc check.  See the
> PatchFile::LoadSourceFile() implementation here:
> https://gitweb.torproject.org/tor-browser.git/tree/toolkit/mozapps/update/updater/updater.cpp?h=tor-browser-31.3.0esr-4.5-1#n1343
> I did check that the "expected crc" value that was logged matches
> that of a versions file that I extracted from https://archive.torproject.org/tor-package-archive/torbrowser/4.5-alpha-1/tor-browser-linux64-4.5-alpha-1_en-US.tar.xz,
> so it seems like the incremental MAR file is correct (side note:  I
> had to create a test program that incorporates the code that Mozilla
> uses to calculate their CRC32 values; the standard crc32 program
> produced a different result).
> It may be difficult to determine at this point, but is it possible
> that your versions file was not from the final 4.5-alpha-1 build?

FWIW, I have the same error in my backup-update.log but for libxul.so
instead of versions. When I saw this, I also puzzled as to if I had
decided to run an earlier build of 4.5-alpha-1 and forgot about that.

It also looks like it tried to patch libxul.so before versions in my
case, and then aborted, so it may have had differences in both places.

Mike Perry
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: Digital signature
URL: <http://lists.torproject.org/pipermail/tbb-dev/attachments/20141211/39017cbb/attachment.sig>

More information about the tbb-dev mailing list