[tbb-bugs] #21838 [Applications/Tor Browser]: Gitian VM creation fails on Ubuntu 16.x machines in the unmount step

Tor Bug Tracker & Wiki blackhole at torproject.org
Thu Jul 6 00:42:09 UTC 2017

#21838: Gitian VM creation fails on Ubuntu 16.x machines in the unmount step
 Reporter:  gk                        |          Owner:  tbb-team
     Type:  defect                    |         Status:  new
 Priority:  Medium                    |      Milestone:
Component:  Applications/Tor Browser  |        Version:
 Severity:  Normal                    |     Resolution:
 Keywords:  tbb-gitian                |  Actual Points:
Parent ID:                            |         Points:
 Reviewer:                            |        Sponsor:
Changes (by dcf):

 * cc: dcf (added)


 Replying to [comment:2 boklm]:
 > I am able to reproduce this error in an Ubuntu 16.10 VM. It seems to be
 caused by `/usr/sbin/update-grub` returning a error when run inside the
 wheezy chroot, and then the cleanup after this error not unmounting things
 in the right order.

 Here's a previous tbb-dev discussion that mentions this problem and has a
 dev/attachments/20160410/8640e727/attachment.patch hack-around patch]:
   I ran into two problems that I tried to fix by patching vmbuilder. The
 first is that the call to `update-grub -y` would fail. I traced the
 problem to a lack of /dev inside the chroot; `update-grub` runs
 grub-probe --device-map=/boot/grub/device.map -t device /
   which fails with
 grub-probe: error: cannot find a device for / (is /dev mounted?).
   For this, I copy-pasted some code to bind-mount /dev before the call and
 unmount it after.

Ticket URL: <https://trac.torproject.org/projects/tor/ticket/21838#comment:4>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online

More information about the tbb-bugs mailing list