[tbb-bugs] #20691 [Applications/Tor Browser]: Updates are not getting properly applied when trying to update to 6.5a4(-hardened) on OS X and Linux

Tor Bug Tracker & Wiki blackhole at torproject.org
Thu Nov 17 11:47:36 UTC 2016

#20691: Updates are not getting properly applied when trying to update to
6.5a4(-hardened) on OS X and Linux
 Reporter:  gk                        |          Owner:  tbb-team
     Type:  defect                    |         Status:  new
 Priority:  Immediate                 |      Milestone:
Component:  Applications/Tor Browser  |        Version:
 Severity:  Critical                  |     Resolution:
 Keywords:  TorBrowserTeam201611      |  Actual Points:
Parent ID:                            |         Points:
 Reviewer:                            |        Sponsor:

Comment (by gk):

 Replying to [comment:5 gk]:
 > Replying to [comment:2 mcs]:
 > > On OSX, I am able to successfully apply the update (the control port
 Unix domain socket is in the `TorBrowser-Data` directory, which is outside
 the scope of what the updater touches, so the ensure_copy problem does not
 occur). But on the OSX system that I used for testing, after the update
 was applied and the browser restarted, tor failed to start. This happened
 because quotes are missing from the `ControlPort unix:...` argument which
 was passed on the tor command line by Tor Launcher (I have spaces in my
 path). But we fixed that problem in Tor Launcher! After a little more
 investigation I learned that Tor Launcher was not updated in the profile
 or in the `TorBrowser.app/Contents/Resources/distribution/extensions`
 directory. I don't know why yet though, and we might need a new ticket for
 OSX. The dmg files have the correct Tor Launcher. I have not checked the
 complete mar files  and I have not done enough analysis to determine if
 the incremental mar files are flawed or if the updater failed to update
 the xpi properly.
 > Interesting. I made a couple of tests taking a fresh 6.0.5 and a fresh
 6.5a3. I tested updating the stable both in a desktop and an /Applications
 location and it worked: the extensions and everything seemed to be fine.
 Note, though, that we only have full updates right now for the stable
 > For the alpha I tested just installing it on the desktop and applying
 the MAR files manually. Both the incremental and the full MAR file applied
 correctly and the extensions were updated, too.

 I tested now putting 6.5a3 to /Applications (getting a space in the user
 dir path) and applying the incremental update manually worked as well. So,

Ticket URL: <https://trac.torproject.org/projects/tor/ticket/20691#comment:6>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online

More information about the tbb-bugs mailing list