[tbb-bugs] #12756 [Tor Browser]: I can't get the TorBrowser 3.6.3 to start fully under my OSX 10.6.8 system.

Tor Bug Tracker & Wiki blackhole at torproject.org
Thu Jul 31 16:27:09 UTC 2014

#12756: I can't get the TorBrowser 3.6.3 to start fully under my OSX 10.6.8 system.
 Reporter:  SciFi        |          Owner:  tbb-team
     Type:  defect       |         Status:  new
 Priority:  normal       |      Milestone:
Component:  Tor Browser  |        Version:  Tor:
 Keywords:               |  Actual Points:
Parent ID:               |         Points:
 [ I initially sent this to help at rt.torproject.org
   then I've cleaned it up and enhanced it s'more
   to insert it into this bug report
   as per recommendation by "Matt Pagan via RT" ]


 I've been trying to use the TorBrowser.app 3.6.2 and now 3.6.3 ---
 I must run MacOSX 10.6.8 (too long to explain here, blame Apple for
 causing my predicament)
 which should be supported by the documentation listed at the
 torproject.org website.

 I used to be able to run the older Tor versions
 which had us run Vidalia.app version 0.2.15 as a separate task
 and the TorButton add-on for Firefox.

 In the recent versions of TorBrowser,
 I am always presented with a pop-up window saying the Tor Launcher has
 and so the TorBrowser won't come up.
 (see attached file named 'cantstarttorbrowserscreengrab.png')

 I might have an idea what's going on.

 Here is a relevant snip of what is in my system.log:

 > Jul 28 11:22:55 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]:
 Failed to find nss3 in installed directory, checking system paths.
 > Jul 28 11:22:55 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: SSL
 Observatory: Failed to initialize NSS component:Error: couldn't open
 library libnss3.dylib
 > Jul 28 11:22:58 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: Jul
 28 11:22:58.565 [notice] Tor v0.2.4.22 (git-345e00dc68a052fe) running on
 Darwin with Libevent 2.0.21-stable and OpenSSL 1.0.1h.
 > Jul 28 11:22:58 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: Jul
 28 11:22:58.786 [notice] Tor can't help you if you use it wrong! Learn how
 to be safe at https://www.torproject.org/download/download#warning
 > Jul 28 11:22:58 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: Jul
 28 11:22:58.850 [notice] Read configuration file
 > Jul 28 11:22:58 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: Jul
 28 11:22:58.851 [notice] Read configuration file
 > Jul 28 11:22:58 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: Jul
 28 11:22:58.880 [warn] Couldn't set maximum number of file descriptors:
 Invalid argument
 > Jul 28 11:22:58 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: Jul
 28 11:22:58.880 [warn] Failed to parse/validate config: Problem with
 ConnLimit value. See logs for details.
 > Jul 28 11:22:58 SciFi [0x0-0xb6cb6c].org.mozilla.torbrowser[63858]: Jul
 28 11:22:58.880 [err] Reading config failed--see warnings above.

 I think it's the warning

 > Couldn't set maximum number of file descriptors: Invalid argument

 We had similar problems with the MakeMKV.app code
 (at <http://www.makemkv.com/>)
 because we've modified several sysctl values
 dealing with such parameters
 at the system level.
 MakeMKV.app was not usable `unless` we started it as Root (Superuser

 I even bought a license
 to properly register MakeMKV.
 No help.

 A bit over a year ago
 I finally opened a ticket
 with the staff there at MakeMKV.
 Mike Chen helped find the reason.
 Let me quote him:

 > [… T]he new logic is to ignore the setrlimit error and hope for the
 best. In your case the value already was big enough.

 That change in the MakeMKV code was all it took to fix it.

 … … …

 I wish I could patch & build the Tor code myself, but let me cover why I
 can't do this.

 My history:

 If you need to know,
 I live in the city where the Murrah building was blown up.
 (see <https://en.wikipedia.org/wiki/Alfred_P._Murrah_Federal_Building>)
 At that time I was recovering from a 2nd operation to hopefully fix an
 inguinal hernia.

 Many other things happened to me,
 including being extra-sensitive to "something" in the air at the office
 where I worked
 which "they" would never deal with properly
 during the years I was there.

 And so,
 I've been on disability for over 7 years now.
 All told, things are not getting any better for me.
 I'm on SSD based on my nearly-40-years work on record.
 I'm actually slated to be fully retired, too.
 My main paid job was in technical matters with state govmt mainframes and
 state-wide networks.
 I was also allowed to build open-source computer desktop systems (FreeBSD)
 in attempts to show how our govmt could save money that way.
 My health got so bad, and many other things, forced me to get on SSD and
 to retire.

 Then our office building was demolished because the Atty General wanted a
 parking lot for their offices.
 [No relation to the Murrah building incident,
   but it makes some of us wonder why "they" need to hide the evidence so
 damn quickly like that.]

 Being forced to work in that office building was the main issue causing my
 Yes a conspiracy was afoot
 but I no-longer have the proof
 even tho Google-Earth has archives of that plot of land
 where I believe my car at that time could be seen being parked there.

 7 years ago I was able to get an iMac to keep me company
 with the initial check/funds sent to me.
 And that's where I am, today.
 I have been unable to properly afford any 'real' desktop system ever
 (I'd be happy for any help.)

 I've had lots of help from our state human services,
 I'm in their "Adult Protective Services" program.

 I'm quite blunt & honest when I say
 I am not crazy
 yet I believe whoever was in charge of my plight
 in the same vein that Crooks are.
 "They" tried many different drugs on me,
 including those that are mind-altering.
 I felt I must make that clear here.

 I believe Apple has been embroiled with conspiracies, too.
 FWIW, for me this started with the switch from PowerPC to Intel.

 Back to current history:

 I can't build big systems anymore.
 Even this iMac won't boot-up on most open-src CD/DVD images.
 Something with the EFI/BIOS, as I see it.
 (Can't even boot-up Tails fully, see.)
 But I _can-usually_ build separate projects
 that will work under Darwin and/or X11/XQuartz
 (such as enough of the GNome libraries and GNU utils et al.
   to let me run the Pan newsreader, for example).

 This iMac is model "iMac6,1"
 which features a 32-bit EFI/BIOS
 but it has a Core-2-Duo CPU
 which does run most tasks in 64-bit mode.
 It is in the same 'family'
 as the early MacPro towers.
 I've fitted the maximum RAM allowed in this model,
 a full 4GB
 comprised of two slots of 2GB each.

 But I didn't know we were going to have such problems
 as those MacPros were having
 when I bought it
 7 years ago.

 I've adjusted many sysctl parms
 in order to make it seem more server-ish
 than end-user-ish.
 I did that thru altered /etc/rc* files,
 /etc/launchd[_user].conf files,
 so we'd always have those values available
 at every boot
 and internal task start.

 I also fitted the 'dnsmasq' project
 (at <http://www.thekelleys.org.uk/dnsmasq/doc.html>)
 in place of the regular DNS code
 to let me control it better
 (mainly to get around the dnscache problem).
 I have OSX pointing DNS on the Network control panel
 to localhost (
 with the dnsmasq running in daemon mode
 listening to DNS type requests,
 which in turn has a huge 'hosts' type file
 to filter-out many many 'bothersome' sites.
 Right now it shows

 > $ dnsmasq --version
 > Dnsmasq version 2.67  Copyright (c) 2000-2013 Simon Kelley
 > Compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP DHCPv6
 no-Lua TFTP no-conntrack no-ipset auth
 > […]

 I let the cable modem do the actual DHCP IP-addy assignments
 (I have several HDHomeRun units on my local network [made by
   and a Xerox printer on the LAN
   and a Mede8er model 500X2 HTPC on the LAN).

 I have many tasks going on here 24/7/365,
 cron-based (timed) and others such as EyeTV (Elgato.com)
 even right now today as I type this note,
 such that I've also had to get two big power UPS's
 to curtail the summertime power blips, too.

 Now I'm fighting the inevitable Heat buildup problem
 during the summertime here.
 I have fans drawing from a floor a/c vent
 blowing onto the back of this iMac.
 I even have a Dremel tool
 in case I must open-up the back
 to forcibly cool the innards.  ;)

 All this would be much better
 if I could ever get a
 real open-src tower/server system.

 Such is Life when in my situation.  ;p

 Now every time I spot a possible incongruity
 with the way I have things operating here
 and the project(s),
 I need to raise an alarm with someone in charge
 to help try fixing it.

 BTW please don't ask why I don't upgrade to OSX 10.7, please don't ask.
 (It is the final official o.s. this model can supposedly run.
   Altho I could try some files that might provide 'faked' 64-bit EFI/BIOS,
   that's only good for booting-up later OSX versions tho
   [not for e.g. Tails etc].
   Otherwise with 10.7 I would lose so many things
   such as Rosetta
   and create [more] sandboxing issues
   etc etc etc etc etc etc etc.
   As long as I can build & update such projects as OpenSSL, GNU stuff, and
   and then link the other projects to them,
   I won't care what Apple does or doesn't do.
   See?  ;p
   But I would _still_ rather have a real open-src tower/server system.
   That's the bottom line for me.

 Sorry this got so long & wordy.

 Thank you/anyone for reading & possible help.

Ticket URL: <https://trac.torproject.org/projects/tor/ticket/12756>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online

More information about the tbb-bugs mailing list