[ooni-dev] Warnings from update-ooniprobe.sh

Vasilis andz at torproject.org
Fri Oct 28 04:04:00 UTC 2016

Hi David,

David Fifield:
> On Wed, Oct 26, 2016 at 06:26:13PM -0700, David Fifield wrote:
>> After booting, my Raspberry Pi doesn't have a web interface (only port
>> 22 is open).
> On IRC, Arturo said this was caused by me using the wrong image. I used
> https://get.ooni.torproject.org/lepidopter/lepidopter-alpha-armel.img.xz
> instead of
> https://get.ooni.torproject.org/lepidopter/lepidopter-v0.3.5-beta-armel.img.xz

Indeed as Arturo mentioned already on IRC this image is quite old and I
guess we should move to an archive instead.

You can always find the latest image in:

> I tried running /opt/ooni/update-ooniprobe.sh as suggested. It produced
> a lot of warnings:

The script `/opt/ooni/update-ooniprobe.sh` run the following commands:

apt-get -y -qq purge python-cryptography

# Update ooniprobe
pip -q install ooniprobe --upgrade
# Update ooniresources
ooniresources --update-inputs

> # /opt/ooni/update-ooniprobe.sh
>   Could not find .egg-info directory in install record for ooniprobe from https://pypi.python.org/packages/72/87/ec83e6464e3e85d149b8cf4286f0568c5f6f9da1bfa5c2ca5097857333ce/ooniprobe-2.0.0.tar.gz#md5=aa17803881aa1c0756c5fa7bbd858f34 in /usr/local/lib/python2.7/dist-packages/ooniprobe-1.4.2-py2.7.egg
>   Could not find .egg-info directory in install record for PyYAML>=3.10 from https://pypi.python.org/packages/4a/85/db5a2df477072b2902b0eb892feb37d88ac635d36245a72a6a69b23b383a/PyYAML-3.12.tar.gz#md5=4c129761b661d181ebf7ff4eb2d79950 in /usr/local/lib/python2.7/dist-packages/PyYAML-3.11-py2.7-linux-armv7l.egg (from ooniprobe)
>   Could not find .egg-info directory in install record for Twisted>=13.2.0 from https://pypi.python.org/packages/6b/23/8dbe86fc83215015e221fbd861a545c6ec5c9e9cd7514af114d1f64084ab/Twisted-16.4.1.tar.bz2#md5=c6d09bdd681f538369659111f079c29d in /usr/local/lib/python2.7/dist-packages/Twisted-16.2.0-py2.7-linux-armv7l.egg (from ooniprobe)
>   Could not find .egg-info directory in install record for scapy>=2.2.0 from https://pypi.python.org/packages/ac/14/c792a14b9f8bc4bb9c74c0594c167a2da36e31964098d9e27202142cbd7d/scapy-2.3.3.tgz#md5=65939356f08760ebef836796d3320b3b in /usr/local/lib/python2.7/dist-packages/scapy-2.3.2-py2.7.egg (from ooniprobe)
>   Could not find .egg-info directory in install record for zope.interface from https://pypi.python.org/packages/38/1b/d55c39f2cf442bd9fb2c59760ed058c84b57d25c680819c25f3aff741e1f/zope.interface-4.3.2.tar.gz#md5=5f7e15a5bcdfa3c6c0e93ffe45caf87c in /usr/local/lib/python2.7/dist-packages/zope.interface-4.1.3-py2.7-linux-armv7l.egg (from ooniprobe)
>   Could not find .egg-info directory in install record for cryptography>=1.3.4 (from pyOpenSSL>=0.15.1->ooniprobe)
>   Could not find .egg-info directory in install record for cffi>=1.4.1 from https://pypi.python.org/packages/0a/f3/686af8873b70028fccf67b15c78fd4e4667a3da995007afc71e786d61b0a/cffi-1.8.3.tar.gz#md5=c8e877fe0426a99d0cf5872cf2f95b27 in /usr/local/lib/python2.7/dist-packages/cffi-1.6.0-py2.7-linux-armv7l.egg (from cryptography>=1.3.4->pyOpenSSL>=0.15.1->ooniprobe)
>   Could not find .egg-info directory in install record for pycparser from https://pypi.python.org/packages/eb/83/00c55ff5cb773a78e9e47476ac1a0cd2f0fb71b34cb6e178572eaec22984/pycparser-2.16.tar.gz#md5=983118bb558ba11754af25647573487c in /usr/lib/python2.7/dist-packages (from cffi>=1.4.1->cryptography>=1.3.4->pyOpenSSL>=0.15.1->ooniprobe)

This warning is kind of "normal" for pip installation.

> WARNING: Usage of this script is deprecated.

ooniresources has been now deprecated in ooniprobe v2.0.0 it now uses an
internal scheduler. This is also not fatal.

> After updating, there was still no webapp listening on port 80. After
> updating (and also after rebooting) there was still no webapp.
> I'm going to try starting over with the correct image, unless you want
> me to try something different.

Upon upgradeing ooniprobe (pip -q install ooniprobe --upgrade) should
have installed the lepidopter-update service that will do the required
updates and bring up ooniprobe service and ensure that the
ooniproge-agent is running.

Do you see the systemd (units) services of lepidopter-update and
ooniprobe with status running?

You can check with:
systemctl lepidopter-update status
systemctl ooniprobe status

If you see that these services are not running you can query the systemd
journal with:
journalctl -l _SYSTEMD_UNIT=lepidopter-update.service

Thank you for running lepidopter!

Fingerprint: 8FD5 CF5F 39FC 03EB B382 7470 5FBF 70B1 D126 0162
Pubkey: https://pgp.mit.edu/pks/lookup?op=get&search=0x5FBF70B1D1260162

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 801 bytes
Desc: OpenPGP digital signature
URL: <http://lists.torproject.org/pipermail/ooni-dev/attachments/20161028/4e6e49c0/attachment.sig>

More information about the ooni-dev mailing list