[metrics-bugs] #28114 [Metrics/Library]: Improve getter names for boolean fields in metrics-lib

Tor Bug Tracker & Wiki blackhole at torproject.org
Fri Oct 26 07:41:15 UTC 2018

#28114: Improve getter names for boolean fields in metrics-lib
 Reporter:  efgyirfe784      |          Owner:  metrics-team
     Type:  enhancement      |         Status:  new
 Priority:  Medium           |      Milestone:
Component:  Metrics/Library  |        Version:
 Severity:  Normal           |     Resolution:
 Keywords:                   |  Actual Points:
Parent ID:                   |         Points:
 Reviewer:                   |        Sponsor:

Comment (by irl):

 I do prefer the isXY() format for boolean getters, but I wonder what to do
 about these in the ServerDescriptor interface. Some suggestions:

 public boolean getUsesEnhancedDnsLogic() -> isUsingEnhancedDnsLogic()
 public boolean getCachesExtraInfo() -> isExtraInfoCache()
 public boolean getAllowSingleHopExits() -> isSingleHopExit()
 public boolean getTunnelledDirServer() -> isTunnelledDirServer()

 A side note: there is a typo in the JavaDoc for getTunnelledDirServer()
 that could be fixed at the same time.

Ticket URL: <https://trac.torproject.org/projects/tor/ticket/28114#comment:3>
Tor Bug Tracker & Wiki <https://trac.torproject.org/>
The Tor Project: anonymity online

More information about the metrics-bugs mailing list